PlayingWithFusion.com Home

0 Items View Cart

Document: 1204
Posted: December 8, 2015
Modified: December 8, 2015

Home > Tech Article Categories > Robotics > ArgoBot Software Installation

ArgoBot Software Installation

ArgoBot setup guide and troubleshooting instructions

Software Installation

  1. If it is not already installed, please install LabVIEW. It may be purchased from Digilent using this link.
  2. Install Linx after LabVIEW is installed. Linx enables communication between LabVIEW and ArgoBot. Its available for download from MakerHub. Additional YouTube video instructions are also available.
  3. Next, download the latest version of rob00001_source.zip from the ArgoBot product page.
  4. Follow the Argobot Setup and Blink Tutorial to ensure everything is connected properly.

Router Settings

The router is pre-configured when shipped. Router settings should only be changed if you are having connection problems.

  1. To access the router setting plug the USB and Ethernet cable into your computer
  2. Turn off your Wifi to assure your computer is communicating through Ethernet
  3. Go to http://tplinklogin.net
    1. User Name: admin
    2. Password: admin
  4. Below are the appropriate settings for your router
  5. If you have more than one robot choose a different SSID should for each ArgoBot
  6. The WPA-PSK password should be set to be the same as the SSID.

ChipKit WF32 Setup

The ChipKIT WF32 is pre-configured as shipment as well. WF32 settings should only be changed if you are having connection problems .

  1. Connect a USB cable to your computer and ChipKIT WF32
  2. Open Labview
  3. Go to Tools > MakerHub > LINX > LINX Firmware Wizard
  4. Select the following
    1. Device Family: Digilent
    2. Device Type: chipKIT WF32
    3. Firmware Program Interface: Serial / USB
  5. Click Next
  6. Select the correct USB port and hit Next
  7. Select the following
    1. Firmware Version : LINX – WiFi
    2. SSID: Argbot_1
      1. This should match your Wifi router SSID
    3. IP Address: 1.2.3.4
    4. Wifi Security Type: WPA2 Key
    5. Port: 1
    6. Password: ArgoBot_1
      1. This should match your Wifi router password
    7. Click Next
    8. Click Finish
    9. Follow the Argobot Setup and Blink Tutorial to ensure everything is connected properly.

Troubleshooting Guide

Robot keeps dropping connection or responding slowly

Step 1
  1. Make sure you router is connected with Ethernet cable
  2. Turn off your Wifi
  3. If this does not fix the issue go to Step 2
Step 2
  1. Check the loop rate
  2. This should be in the green
  3. If loop rate is in the yellow or red you may have to many features on.
  4. Turn off some feature to increase loop rate
  5. If this does not fix the issue go to Step 3
Step 3
  1. If you have a Wifi analyzer check to see if there is a lot of traffic on the channel you are on. The default channel is 1.
  2. Connect your router with the USB and Ethernet cable to your computer
  3. Go to http://tplinklogin.net
  4. Go to Wireless > Wireless Settings. Change the channel to the channel with the lowest traffic.
  5. Click Save and reboot the router
  6. Try this until you find a channel that works
  7. If this does not fix the issue contact Technical Support

Robot will not connect

Step 1
  1. Turn the robot off
  2. Fully disconnect the router
  3. Shut down LabVIEW
  4. Follow the ArgoBot Setup and Blink Tutorial
  5. If this does not work go to Step 2
Step 2
  1. Charge the battery and repeat step 1 once battery is charged
  2. If this does not work go to Step 3
Step 3
  1. If you have more than one ArgoBot, make sure the router and ArgoBot SSID and WPA-PSK match
  2. If still having connection problems go to Step 4
Step 4
  1. Check the battery voltage using a volt meter
  2. If fully charged and the voltage is not above 6v you may have drained the battery to low and the battery will need to be replaced. Never store the robot turned on as this will cause damage to the battery.
  3. If you measure 6v or above but are still unable to connect go to Step 5
Step 5
  1. Reconfigure the ChipKIT WF32 board as shown in the ChipKIT WF32 Setup section above.
  2. If this does not work go to Step 6
Step 6
  1. Reconfigure the router as shown in the Router Setup section above
  2. If this does not fix the issue contact Technical Support

Related Products